にしし ふぁくとりー:西村文宏 個人サイト

てがろぐ リリースノート

お手軽マイクロブログCGI「てがろぐ」のアップデート案内です。新機能や更新した仕様、新しいスキンなどを案内しています。
更新点だけではなく全体の機能説明をお読みになりたい場合や、CGIそのものをダウンロードしたい場合は、てがろぐ配布ページへお越し下さい。
セットアップやバージョンアップの前に最新版の使い心地を試したい場合は、動作テスト用てがろぐをご使用下さい。
次期バージョンの開発進捗状況をチェックしたい場合は、開発進捗報告ページをご覧下さい。

《最終更新: 2021年09月23日 木曜日 14時22分 》 RSSフィード

タグ「不具合報告」を含む投稿[1件]

Perlのバージョンが新しいとInternal Server Errorになる問題について #不具合報告

先日に公開した「てがろぐ Ver 2.4.0」について、一部の環境では新規セットアップでもバージョンアップでもInternal Server Errorになることが分かりました。

(この件は解決済みです。)

例えば、さくらインターネットのレンタルサーバをお使いで、Perlのバージョンを「標準のPerl(推奨)」に設定している場合、自動的に最新のPerlが使われるようになるため(現時点ではPerl 5.26.3が使われるようです)、てがろぐ Ver 2.4.0 をセットアップするとInternal Server Errorになって動作しないことが分かりました。これは別に「さくらインターネット」に限らず、てがろぐCGIをセットアップしようとするレンタルサーバで、Perlのバージョンが5.26あたり以降の場合にはどこでも発生します。

明日あたりに修正版 Ver 2.4.1 をリリースする予定でおります。もし、Internal Server Errorになってしまって「どうやっても動かないよ!」という方はその Ver 2.4.1 をお待ち頂き、それをご使用下さい。
既に公開済みの新バージョン 2.4.2 で解消しておりますので、そちらをご使用下さい。

なお、明日まで待てない! という方は、(レンタルサーバのコントロールパネルでPerlのバージョンを選択可能な場合には)例えば下図のように Perl 5.14.4 などを選択すれば動くようになります。Perl 5.20でも動くと思いますが。しかし、あえてPerlのバージョンを落とす必要性もありませんし、他のCGIの動作に影響しても困りますので、明日リリースする、てがろぐVer 2.4.1 をお待ち頂く新バージョンをご使用頂く方が良いと思います。
20200108223617-nishishi.png

※この問題は、てがろぐ Ver 2.3.0以下では発生しません。
今すぐに「てがろぐ」を新規セットアップなさりたい場合で、Perlのバージョンを変更できない場合は、Ver 2.3.0をダウンロードしてご使用下さい。(配布ページでは、最新版の他に、過去3バージョンまで公開しています。)
畳む

:964文字 修正

DASHBOARD

■リリースノート内を検索:

■最近の投稿:

■その他のご案内:

▼現在の公開バージョン:

配布版:Ver 3.4.0

▼ご質問やご要望がある場合:

ご質問やご要望がある場合は、動作テスト用てがろぐもご利用下さい。事実上のサポート掲示板にもなっておりますので。(^_^;)

編集

■日付検索:

▼現在の表示条件での投稿総数:

1件

このリリースノートも、てがろぐCGIを使って生成しています。
てがろぐCGIでページの生成に使用しているスキンファイルの実体は普通のHTMLファイルですから、一般のウェブページと同様の手順で自由に書き換えられます。

Powered by てがろぐ Ver 3.4.0.

--- 当サイト内を検索 ---